Régulation haute tension

Amplification - Pré-amplification.
Tubes, Transistors, Hybrides.
Vintage ou récent.
Réalisations personnelles.

Modérateur: VR150

Régulation haute tension

Messagepar JBERT » 17 Oct 2018 18:54

Bonsoir à tous,

Dans le prolongement de mes alimentations résonnantes à haute tension, j'essaie de mettre au point une régulation à découpage permettant de passer d'une tension d'entrée de 280 à 500V à une tension de sortie de 250V.

Mes alimentations résonnantes fonctionnent à 100 kHz. J'utilise donc l'horloge carrée de ces alimentations que je fais passer dans un comparateur à hystérésis et un genre d'intégrateur contre-réactionné pour obtenir un magnifique triangle à 100 kHz qui est le signal T du schéma.

convertisseur_CC_CC.jpg
convertisseur_CC_CC.jpg (171 Kio) Vu 124 fois


Le schéma est un peu en mode brouillon, il s'agit du schéma de travail pour Spice. J'espère que vous ne m'en voudrez pas.

Je ne peux pas utiliser comme transistor de puissance un MOSFET canal N car je n'ai pas trouvé sur étagère un transfo flyback avec les bonnes caractéristiques. J'utilise donc une ruse : un MOSFET canal P et un optocoupleur. Le 6N136 n'a pas beaucoup de gain mais une bande passante suffisante. Problème : il m'est impossible d'utiliser directement sa sortie sur un transistor bipolaire, le courant de base déstabilisant le 6N136 (ça fiche en l'air le temps de montée de la photodiode). Je sors donc sur un MOSFET canal N qui attaque un bipolaire. Le signal CC1 est propre (excursion de 10V, le temps de descente est plus rapide que le temps de montée, mais globalement, il est largement suffisant pour ce que je veux en faire).

Là où ça coince, c'est entre Q3 et Q4. Il s'agit pourtant d'un driver classique que j'utilise souvent mais quelque chose m'échappe. D2, D3, D4, D5 et D6 sont des 1N4148. C5 est un condensateur pour bootstraper le push-pull. Et le signal sur la grille de Q1 est parfaitement ignoble. Si le temps de descente (vers ON) est correct, il n'est pas encore remonté qu'il se prend une autre commande d'ouverture. La capacité de grille me joue des tours et je ne vois vraiment pas comment l'aider à se vider plus vite...

Je prendrai tout idée.

Bien cordialement,

JB
Fabricant et réparateur d'amplificateurs audio
Locaux à Paris et Brive-la-Gaillarde
http://www.systella.fr
Avatar de l’utilisateur
JBERT
 
Messages: 147
Enregistré le: 19 Juil 2017 22:28
Localisation: Brive-la-Gaillarde (juste à côté)

Re: Régulation haute tension

Messagepar JBERT » 18 Oct 2018 14:13

Je crois que j'ai trouvé. il faut virer R4 et remplacer Q6 par un push-pull de MOS.
Fabricant et réparateur d'amplificateurs audio
Locaux à Paris et Brive-la-Gaillarde
http://www.systella.fr
Avatar de l’utilisateur
JBERT
 
Messages: 147
Enregistré le: 19 Juil 2017 22:28
Localisation: Brive-la-Gaillarde (juste à côté)


Retourner vers Amplification

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité